あっちこっちケイイチ サーバーライフ

よたかの日記を兼ねたブログです

8月にやってくる憂鬱よたか

CPI の シェアードプランACE01 のバージョンアップがはじまるらしいのです。

Apacheが2.2になるらしいのですけど、これは良い。
一応2.2で動くように準備してましたから。

問題はPHPのバージョンが5.5推奨なる事。
中には7.0推奨とかいうアプリも出てきた。ヤバいな。
まだチェックが終わってないアプリが結構あるよ。

Nucleusは3.71はPHP7でも動くのだけど、プラグインが全滅っぽい。
NetcommonsもPHP7は多分ダメだと思うけど、PHP5.5ならちゃんと動きそう。
自分で作ったアプリはなんとでもなると思うので、とりあえずサポート費用でなんとか対応しようと思ってます。

実はWAFに対応できてないCMSが結構あるみたいだけど、一番の問題は外注で作って貰ったアプリたち。
把握できてない部分が結構ある。

今から洗い直しすれば多分なんとか間に合うと思うんだけど、どのサーバーからアップグレードしてくのか情報が来てないみたいだし、ちょっと困った。

案内をみると、とりあえずPHP5.3がそのまま使えるらしいのだけど、一応相談だけしたほうがいいかもしれない。

今年の夏は結構キツそうな予感です……。

ACE01 ウェブサーバーに関する重要なお知らせ